Electrical Sphere Wireless Lights

Hubble80

Well-Known Member
Nov 22, 2012
521
299
63
Moranbah, QLD
#1
Hey guys,

I am having A LOT of drama with the wireless lights in the new Starcraft. In the last week a few of the channels on each receiver have been lit up all the time. This means that when the switch is turned on, the lights turn on for about one second then go off. If you push the OFF button, on channel turns on then off again.

Very frustrating. I now have four channels on the blink and have next to no lights working in the van. Anyone know anything about how to reset these things. I have tried everything in the paperwork that came with the van, but nothing has worked...
 

ShaneT

Well-Known Member
Jul 24, 2014
291
308
63
W.A
#4
I was talking to my local caravan repairer (still trying to sort warranty work) about electrical diagrams for jaycos. He said they don't do anything and the latest jayco drama is the new wireless lighting failing. The drama is you have a bunch of wires going into a brain box that are not labelled so you have to wok out what light each wire goes to so then you can allocate each wire a switch.
I suppose what I am saying is it must be a known fault and you should get it done as warranty, and/or maybe since it is still half working label the wiring before you loose the lot.
 
Jul 5, 2015
13
15
3
61
Blue Mountains
#13
Just new to the forum today and read with interest this posting about the Sphere lighting. I also had a recent experience with our lighting in our 2013 Sterling Outback poptop when the lights suddenly stopped working from the switches. Fortunately the lights can still be turned on and off using the small buttons on the front of the Sphere control box, but this does necessitate leaning into the back of the pantry to turn them on and off. I initially attempted to reprogram the light switches to the Sphere control unit but the programming would not register, however, two days later when I was just about the replace the Sphere control unit the programming function decided it would work. All the lighting is once again functioning as before. Should the Sphere control unit need replacing they cost about $120.
 
Jan 30, 2013
72
81
18
Perth
#18
If the green light stays on on the mai sphere unit, the relay is stuffed in the unit and the unit needs to be replaced. I had the problem in my new starcraft and they said its the relay in the unit and replaced it. If the switches on the walls do not turn the sphere units on and off, check that the batteries in the wall switches are not flat. Each wall switch takes 2 x 3032 batteries.

I hope this helps

Greg
 
Likes: mfexpanda

Hubble80

Well-Known Member
Nov 22, 2012
521
299
63
Moranbah, QLD
#20
Well I got two new receivers from Jayco under warranty. I have fitted them and programmed them up as I want them bar the light in the awning roll.

I cannot get the all OFF function to work, anyone have any idea on how this works or how to do it? Manual for the switches would be ideal, but I am having difficulty getting these from Coast to Coast RV (distributor)...